Miscelánea, Recursos

Error al iniciar Xampp en Windows 10

2 5046

Es posible que si tienes montado un servidor local y has actualizado a Windows 10 Xampp te muestre una pantalla como esta.

xampp_error

En realidad el problema viene porque el sistema operativo utiliza el puerto 80. Existen dos posibles soluciones.

1-. Parar el servicio de publicación World Wide Web
  • Para ello busca con la lupa la barra de herramientas inferior services.msc
  • Clica sobre el resultado que da la búsqueda para cambia la configuración
  • Verás muchos servicios y debes buscar el “servicio de publicación World Wide Web”
  • Una vez encima pulsa el botón contextual del ratón y detén el servicio
  • Reinicia xampp y violà

Esta solución hay que aplicarla cada vez que arranques el sistema así que si quieres puedes cambiar la configuración del servicio para no se ejecute al arrancar Windows.

2-. Cambiar el puerto
  • Deshabilita todos los módulos del XAMPP (Boton Stop) y cierra el Panel de Control.
  • Ves a inicio > Todas las aplicaciones > Sistema de Windows > CMD : Ejecutar como administrador
  • Copiar y pegar lo siguiente sin las comillas "net stop W3SVC" y presionar Enter
  • Aparecerá una pantalla como esta:

info1

  • Volvemos a abrir el Panel de Control de XAMPP e iniciamos los módulos que necesitemos. El que daba error era el de apache que es el que tiene el problema con el puerto 80.
  • Ya iniciará correctamente:

inicio

  • Volvemos al CMD y pegamos, otra vez y sin comillas, "net start W3SVC" y Enter.

info

El servicio cambiará su puerto a otro disponible y la próxima que vez que inicies windows seguirá con ese puerto. La ventaja de esta solución sobre la primera es que no hay que modificar el servicio y/o pararlo. ¿Tenéis alguna solución más para este pequeño problema?

Compartir:

Posts relacionados

2 Comentarios

  1. iqudoblev 4 Enero, 2016 en 2:42 pm -  Responder

    No tengo W3SVC me dice que no es un servicio valido en windows 10

    • Exdeus 14 Enero, 2016 en 3:43 pm - 

      Hola iqudoblev,
      Si te comenta eso es que en realidad no está iniciado el servicio. ¿Qué error te da el Xampp? En algún caso me he encontrado que tenía Skype abierto y Apache no se puede iniciar porque aparece como “Busy” sin ningún tipo de error más. Cerrando la sesión de skype se arregla el tema

Deja una contestación

Tu email no será publicado. Los campos obligatorios están marcados *

2 × 1 =

XI Edición Relatos Solidarios

Publicidad

Comentarios recientes

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.

ACEPTAR
Aviso de cookies